Sie sind nicht angemeldet.

1

Mittwoch, 23. Januar 2019, 12:07

DosBox unter Win 10

Auf Marcus' Anregung im SDK-Thread wollte ich zunächst mal sehen, ob ich Geos in der DosBox unter Windows 10 zum Laufen bekomme. Nun bin ich gewiss nicht der Konfigurationsfreund, aber es gelang mir, Geos zu starten. Was für ein Erlebnis! Der View blieb grau, ein Klick auf z.B. das World-Symbol brachte den View kurz zum Flackern, mehr nicht. Die Laufwerkssymbole ( c und Z) funktionierten, aber in C konnte ich keinen Ordner öffnen. Im Menü wählte ich dann den Verzeichnisbaum und konnte mit dessen Hilfe den World-Ordner öffnen. Jeder Versuch, eine Applikation zu starten, wurde mit einer Fehlermeldung quittiert.
Hat jemand ein unter Windows 10 einwandfrei laufendes Ensemble? Dann würde ich mich sehr freuen, wenn derjenige mir seine DosBox-Konfiguration und auch seine Geos.ini-Datei zukommen lassen könnte.

Wilfried

2

Mittwoch, 23. Januar 2019, 18:04

Hallo Wilfried,
Auf meinem Dienstrechner läuft GEOS (BBX 4.1.3) in der DosBox ohne Probleme, ohne dass ich Konfiguartionsklimmzüge machen musste. Ursprünglich Win10 Home, jetzt Win10 Pro. Wobei ich es unter Pro noch nicht gestartet habe, glaube ich. Muss ich morgen gleich mal probieren und bringe dann auch die INI mit.
Die Ini von meinem GEOS unter Win7 / DosBox geht dir gerade per PM zu. Eventuell hat die aber ein Sound-Problem.

Hast du GEOS unter einem anderes System in der Dosbox?

Was GEOS auch übel nimmt ist in der Wurzel installiert zu sein (SP_TOP = C:\)

Gruß
Rainer
Es gibt 10 Arten von Menschen - die einen wissen was binär ist, die anderen nicht.

3

Mittwoch, 23. Januar 2019, 18:50

Danke Rainer, hat aber leider keine Veränderung gebracht.

Ich habe die Pro-version 32 Bit.

Ein Ensemble-Umzug in eine andere Partition hat ebenfalls nichts verändert.

Bisher hab ich Geos ausschließlich unter XP gefahren (bis auf einen Seitensprung mit einem Android-Tablet;-)).

Wilfried

4

Mittwoch, 23. Januar 2019, 20:50

Der View blieb grau, ein Klick auf z.B. das World-Symbol brachte den View kurz zum Flackern, mehr nicht. Die Laufwerkssymbole ( c und Z) funktionierten, aber in C konnte ich keinen Ordner öffnen. Im Menü wählte ich dann den Verzeichnisbaum und konnte mit dessen Hilfe den World-Ordner öffnen. Jeder Versuch, eine Applikation zu starten, wurde mit einer Fehlermeldung quittiert.
Hat jemand ein unter Windows 10 einwandfrei laufendes Ensemble? Dann würde ich mich sehr freuen, wenn derjenige mir seine DosBox-Konfiguration und auch seine Geos.ini-Datei zukommen lassen könnte.

Hast du schon mal versucht, dich durch die Anleitung hier zu arbeiten? Damit habe ich meine Konfiguration abgeglichen und dann ging es ziemlich problemlos. Am wichtigsten ist wohl

Quellcode

1
fs = ntfat.geo

in der geos.ini, aber bei dir startet es ja zumindest, also dürfte das Filesystem wohl ok sein. Mehr habe ich an der geos.ini nicht gemacht.

Meine komplette DOSBox-Config habe ich mal angehängt.

ciao marcus
»mgroeber« hat folgende Datei angehängt:

5

Donnerstag, 24. Januar 2019, 10:06

Danke Marcus.
Deine Config-Datei hat mich veranlasst, den autoexec-Teil zu betrachten. In meiner Config-Datei stand hier der Mount-Befehl: mount c: f:\ensemble. Das war der Fehler und das meintest du, Rainer, wohl auch mit <<Was GEOS auch übel nimmt ist in der Wurzel installiert zu sein >>. Hatte ich wohl vor einiger Zeit vom Tabletrechner übernommen. Jetzt aufgelöst:
mount c: f:\
cd ensemble
go

Jetzt funktioniert's :) .

Wilfried

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Wilfried« (24. Januar 2019, 12:02)


6

Donnerstag, 24. Januar 2019, 13:32

Sach ich doch. GEOS in der Wurzel geht nicht. 8)Gruß
Rainer
Es gibt 10 Arten von Menschen - die einen wissen was binär ist, die anderen nicht.

Frank9652

Fortgeschrittener

Beiträge: 366

Beruf: Backup-Administrator

  • Nachricht senden

7

Freitag, 1. Februar 2019, 00:00

Bei mir läuft Geos in der Wurzel im Verzeichnis C:/ENS413 unter Win10.

Die Konfigurationsdatei von DosBox Megabuild befindet sich im Verzeichnis
Benutzer/Admin/Appdata/Local/DOSBox/dosbox-SVN_MB6,conf
Johannes meinte damals, dass das so sein müsste.
Ich habe die Konfigurationsdatei auch mal hier angehängt.

DOSBox selber befindet sich aber im Verzeichnis
C:/Program Files/DOSBox_MB6

Johannes hatte es mir damals so installiert.
Er hatte mir damals Megabuild 6 installiert weil er meinte, dass das einige Vorteile gegenüber der 0,74er Version hätte. Welche aber das weiß ich nicht - ist zu lange her.Habe seitdem aber keine Probleme gehabt. Läuft alles wie geschmiert.

Nur beim Beenden muss man manchmal zusätzlich die Shift-Taste drücken.ich habe sehr lange gebraucht bis ich die Ideale Anzahl der Cycles für meinen EeePC gefunden hatte, bin dann bei 110000 cycles gelandet. Schneller wird Geos bei meiner CPU nicht mehr.

Gruß Frank
»Frank9652« hat folgende Datei angehängt:
Geos x Asus EeePC 1015PN + SSD = doppelte Lichtgeschwindigkeit zum Quadrat

8

Freitag, 1. Februar 2019, 12:30

Hallo Jungs, ich glaube da liegt einfach gelegentlich eine Begriffsverwechselung vor, die daher rührt, dass Windows-User in Bezug auf DOSBox mit zwei Laufwerken C: zu tun haben.

Wenn Windows-User von LFW C: sprechen, meinen sie verständlicher Weise in erster Linie das Laufwerk ihres Windows-Systems. Wenn User anderer Host-Systeme (wo es kein LFW C: gibt) von LFW C: sprechen, meinen sie meist das virtuelle LFW C: der DOSBox.

Ich habe da mal mit einem Programmierer, dessen Initialen RB lauten :D locker aneinander vorbei geEmailt, weil der eine das WIndows C: meinte und der andere das virtuelle DOSBox C: Daraufhin habe ich versucht, die Clipper-Hilfedatei exakter zu formulieren, um den Unterschied klarer zu machen.

Dass man das Wurzelverzeichnis C: seines Windows-Systems nicht als DOSBox-Wurzelverzeichnis C: missbrauchen sollte, liegt ja auch auf der Hand. DOSBox kann z.B. nicht mit langen Windows-Dateinamen und den Zugriffsrechten umgehen. Stellt euch vor, was passiert, wenn ihr unter DOSBox im Windows-Dateisystem herum werkelt...

Unter Windows wird also ein Unterordner angelegt, in welchem GEOS installiert wird. Dieser Unterordner wird von DOSBox als LFW C: eingebunden.

Das Problem hatte ich auch irgendwo im Infotext zur DOSBox-Config-Datei erwähnt. http://www.geos-infobase.de/DOSBOX.HTM
Bernd

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Ähnliche Themen

Thema bewerten