Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GEOS-InfoBase-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Mittwoch, 8. September 2021, 21:17

Ich drehe am Rad…

Hallo!

An alle, die Geos unter einem nackten DOS nutzen: Könntet Ihr mal bitte das „PS2MTEST“-Programm aus diesem ZIP-File bei Euch ausprobieren?!
http://bretjohnson.us/programs/usbdos.zip
Es sollte bei angeschlossener Maus einen von drei Fällen anzeigen:
  • No IntelliMouse = kein Rad, bis zu drei Tasten
  • IntelliMouse = ein Rad, bis zu drei Tasten
  • IntelliMouse 2 = bis zu zwei Räder, bis zu fünf Tasten

Und könntet Ihr dann mal die Maus bewegen, die Tasten drücken und am Rad drehen und dabei überprüfen, ob die Anzeige Sinn macht?
Hintergrund der Frage: Wenn ich einige USB-Mäuse (mit Rad) bei meinem Compaq-DOS-Laptop über USB anschließe, wird unter DOS nie ein Rad erkannt. (Im BIOS ist ein „Legacy Mode“ aktiviert, der DOS vorgaukelt, dass USB-Mäuse/-Tastaturen am PS/2-Port angeschlossen seien. Scheinbar ist das BIOS hier „unvollständig“.) Wenn ich hingehen die Mäuse mittels Hardware-Adapter wirklich am PS/2-Port anschließe, dann erkennt PS2MTEST hingegen bei fast allen Mäusen „IntelliMouse“. Hier geht dann das Rad bei den DOS-Programmen, die das unterstützen.
Ganz konfus ist das Ergebnis aber in Emulatoren, z.B. in der „VirtualBox“: Hier wird zwar „IntelliMouse 2“ erkannt, aber Bewegungen der Maus werden als Tastendrücke der Mausknöpfe 4 und 5 oder als Bewegungen der Mausräder angezeigt… (scheinbar ein Fehler im Emulator)…

Grüße und Dank
Jörg
There are two rules in life:
1. Never give out all of the information.

2

Donnerstag, 9. September 2021, 20:56

Hallo Jörg,

Ich habe das ganze einmal auf einem Toshiba Satellite-Notebook unter FreeDOS getestet:
Meine USB-Maus hat 3 Tasten und ein Mausrad. Hersteller ist Noname (Vivanco)
Das Programm PS2MTEST erkennt jedoch keine IntelliMouse und das Drehen am Rad wird entsprechend auch nicht erkannt.
Auch mittels Kommandozeilenoption "1" oder "2" war da nichts zu machen.
Stelle ich den Legacy-USB-Modus im BIOS (PhoenixBIOS) auf DISABLED, so erkennt PS2MTEST überhaupt keine Mausbewegungen und ~tastendrücke mehr. In beiden Fällen hatte ich vorher keinen Maustreiber installiert.

Viele Grüße,
Mario

3

Freitag, 10. September 2021, 17:04

Also so wie bei mir... Danke.
There are two rules in life:
1. Never give out all of the information.

4

Montag, 13. September 2021, 21:41

Hallo Jörg,

um eine Intelli Mouse nutzen können, mußt Du schon die im Paket enthaltenen USB-Treiber verwenden. Ich habe zum Testen auf dem Igel 3/4 (3210) USB aktiviert aber OHNE legacy Emulation und dann USBUHCIL+USBMOUSE unter DOS geladen. Meine "MS Basic Optical Mouse" wird vom Testprogramm auch korrekt als Intelli Mouse 2 erkannt. Alle 3 Buttuns und das Mauserad funktionieren. Das ganze kostet halt nur 37kB UMBs...

Gruß Thomas

Ähnliche Themen