Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GEOS-InfoBase-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Frank9652

Fortgeschrittener

  • »Frank9652« ist der Autor dieses Themas

Beiträge: 427

Beruf: Backup-Administrator

  • Nachricht senden

1

Freitag, 16. Oktober 2009, 23:38

BBE 4.13 - Was mir so auffällt...

Hallo Leute!
Nachdem es ja so einige gibt, die an der Sammelbestellung teilgenommen haben, könnten wir ja an dieser Stelle positive- wie auch negative Sachen aufschreiben, die uns bei BBE 4.13 gegenüber anderen Versionen aufgefallen sind (ob sie nun wichtig oder unwichtig sind).

Na dann will ich mal den Anfang machen... ;-)

Positiv - Das System scheint stabiler zu laufen, als 4.022

GEOMANAGER
1). Version 4.13 zeigt immer noch nicht korrekt den freien Speicher von Datenträgern an, wenn dieser mehr als 2 GByte beträgt. Datenträger > 2 GByte sind zwar unter BBX komplett nutzbar, in der Statuszeile von GeoManager (Motif) werden aber nur maximal 2.097.088 KB freier Speicher angezeigt.

2). Ich verwende gerne die altbewährte Motif-Oberfläche mit dem liebgewonnen Einheitsgrau, und habe gerne die Uhr als Hintergrundprogramm unten rechts. Aber wenn man bei der Uhr als Hintergrundfarbe das Einheitsgrau (rot 170, grün 170, blau 170) auswählt, ist es ein anderes Grau als das der Motif-Oberfläche. Erst wenn man den Grauwert auf (rot 187, grün 187, blau 187) ändert, unterscheidet er sich nicht mehr von dem Grauton der Motif-Oberfläche.

10). Natürlich fehlt weiterhin im Menü "Hilfsmittel" die Funktion "1.x Dokumente updaten".
...da gabs doch mal einen Patch wenn ich mich nicht irre?

GEOS.INI
3). Einige Einträge in der Geos.ini bezüglich Icons sind doppelt -> das habe ich aber erst nach der Installation einiger Programme bemerkt. - Weiß jetzt nicht, ob das vom System herrührt, oder der Installation der Zusatzprogramme.

9). Am System scheint viel herumgeschraubt worden zu sein.
So fehlen bei mir in der Geos.ini die Treiber für das Speichermanagement z.B. (ms4.geo, os2.geo, ntfat.geo, emm.geo, xms.geo etc.) komplett.
Meine Vermutung geht in die Richtung, daß man sich diesbezüglich der DOS-Treiber bedient und die Geos-Treiber als Zwischeninstanz weggelassen hat.
- Das sehe ich als Vorteil bezüglich der Stabilität des Systems.
-So hat sich einiges in der Geos.ini getan, bezüglich Eintragungen, die ich vorher noch nie gesehen habe.

4). Die Registriernummer scheint nicht mehr in der Geos.ini gespeichert zu sein. Mein Eintrag in der Geos.ini lautet: serialnumber = 0000-0000-0000-0000
Die Seriennummer wird auch vor der eigentlichen Geos-Installation abgefragt, was den Verdacht hegt, daß die Seriennummer nun anderswo (ewtl. verschlüsselt) abgespeichert wird.

SYSTEMDATEIEN
5). Im Grundverzeichnis von Geos befinden sich auch zwei Windows-Icons.
Die Icons von BBX 4.13 kann das Programm "Win-ICO View" nicht anzeigen (GONZO hat keine Probleme).
Bei näherer Betrachtung stellte sich heraus, daß die Icons aus BBX 4.13 das Datum 27.02.2003 tragen, während die Icons aus BBX 4.022 das Datum 29.04.2003 tragen.
-Vielleicht sollte man bei noch mehr Systemdateien das Datum vergleichen. Vielleicht stellen wir dann bei noch mehr Systemdateien fest, daß die ältere Version neuere Systemdateien enthält. - Ein Schelm, wer böses dabei denkt.

11). Auf dem Libretto funktioniert bei BBx 4.13 nur der Geos-Tastaturtreiber "Deutsche Tastatur (Standart mit 102 Testen) korrekt obwohl das bestimmt keine Standarttastatur mit 102 Tasten ist.

Bei meiner vorherigen Version 4.022 hatte ich als Tastaturtreiber "Dvorak Tastatur" eingestellt gehabt.
Da bekomme ich aber alles mögliche angezeigt, nur nicht die Tasten, die ich gedrückt habe.

VOREINSTELLUNGEN
6). Folgende Buttons fehlen unter den Voreinstellungen ganz - bin mir dabei aber nicht sicher, ob die mitgeliefert werden, oder ob die durch ein Zusatzprogramm zusätzlich installiert werden.
"Task-Umschalter"
"TCP/IP"
"Verbinden"

ICON-EDITOR
7). Dateien, die mit dem Icon Editor erstellt wurden, haben jetzt ein schönes eigenes Icon im GeoManager.

8 ). Als ich jetzt den Icon-Editor unter BBE 4.13 benutzen wollte, stellte ich fest, daß er nicht mehr instabil läuft.
Da der Editor sich nicht verändert hat, kam nur das System, oder die Token_da.000 in frage.
Also sicherte ich die Token_da und kopierte die Token_da meiner vorherigen Version BBE 4.022 rüber.
- Nun ist der Editor wieder abgestürzt.
Erkenntnis: Irgend etwas muß an/in der Token_da sein, daß den Editor instabil werden läßt. Mir fallen da folgende Möglichkeiten ein:
a). Zu viele Icons
b). Bestimmte Icons die irgendwie defekt sind.
Fazit: Möchte man ältere Icons aus der alten Token_da übernehmen wollen, sollte man nicht die komplette Token_da einfach ersetzen, sondern nur einzelne Icons z.B. über das Programm "Token Loader Pro" in die aktuelle Token_da übernehmen. Anschließend sollte man versuchen, das Icon mit dem Icon-Editor aus der Token_da zu laden.
-Gelingt das ohne Absturz, kann man davon ausgehen daß das Icon i.o. ist.
- Dieser Tipp beruht aber nur auf Vermutungen von mir.

Gruß Frank
Geos + Lenovo Ideapad 5 = Aufbruch in eine neue Galaxie

Dieser Beitrag wurde bereits 13 mal editiert, zuletzt von »Frank9652« (19. Oktober 2009, 05:08)


2

Samstag, 17. Oktober 2009, 01:34

RE: BBE 4.13 - Was mir so auffällt...

Hallo,

Zitat

Original von Frank9652
Vielleicht sollte man bei noch mehr Systemdateien das Datum vergleichen. Vielleicht stellen wir dann bei noch mehr Systemdateien fest, daß die ältere Version neuere Systemdateien enthält.


so viel würde ich auf das Datum nicht geben, da sich das durch div. Sachen ändern kann, ohne daß sich der Inhalt ändert. Ich habe es neulich z.B. geschafft, daß 5 Dateien auf meiner Platte nach dem Entpacken das Datum 10.10.2050 hatten. Auch ältere Daten sind kein Problem - bei meinem Laptop stellt sich z.B. die Uhr gerne mal auf 0:0:0 am 1.1.2000 zurück. (Hast Du die unterschiedlichen Icons mal von WinMerge oder so vergleichen lassen?)
Bei den Systemdateien würde ich eher die einkompilierten Geos-Versions- und Protokollnummern vergleichen... (die müssen zwar auch nichts heißen, wären aber wenigstens einen Tick "sicherer" als das Datum).

Zitat

Original von Frank9652
..., "Task-Umschalter", ...


Fehlen auch schon bei BBE 4.010. Das verwundert aber auch min. beim "Task-Umschalter" nicht. Denn es wird sowieso kein Task-Switcher mehr mitgeliefert (Ausnahme: der "Non-Switching"-Driver, der aber sowieso nichts tut). Macht aber auch nichts, da wohl mittlerweile keiner mehr etwas mit dem "TaskMax Task Driver" anfangen könnte. Auch Marcus' "OS/2 Task Switching Driver" scheint mittlerweile etwas praxisfern zu sein... (sofern er überhaupt noch unter BBE funktioniert).

Gruß,
Jörg
:D Most favorite keys by profession: astronauts: space, pirates: enter, German teachers: 6... :D

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »jpolzfuss« (17. Oktober 2009, 01:46)


3

Sonntag, 18. Oktober 2009, 10:21

RE: BBE 4.13 - Was mir so auffällt...

Hallo

Zitat

Original von jpolzfuss
Das verwundert aber auch min. beim "Task-Umschalter" nicht. Denn es wird sowieso kein Task-Switcher mehr mitgeliefert (Ausnahme: der "Non-Switching"-Driver, der aber sowieso nichts tut). Macht aber auch nichts, da wohl mittlerweile keiner mehr etwas mit dem "TaskMax Task Driver" anfangen könnte.


Besser wäre gewesen, den GEOS-TaskTreiber für DRDOS/NovellDOS/OpenDOS endlich zu verbessern. Stattdessen wird er einfach weggelassen. Das fällt mir leider seit längerem auf. BBE läuft nach wie vor nicht wirklich sauber ohne DOS. Dennoch wirft man für DOS wichtiges einfach über Bord. DRDOS ist eben das DOS, für welches PC/GEOS beworben wurde. Und EH-OpenDOS ist das ideale aktuelle DOS für PC/GEOS. DOS Task-Switchen mit heutigen RAM Größen, vielleicht sogar in dem Teil des schnellen Grafikkartenspeichers den PC/GEOS gar nicht benötigt. Das wäre eine lohnenswerte Idee für einen neuen modernen Task-Switcher für DOS/GEOS Systeme.

Tschau


http://www.drdos.com/dosdoc/usergeng/13ugch13.htm
http://www.drdos.com/dosdoc/usergeng/10ugch10.htm#539

4

Sonntag, 8. November 2009, 11:14

Druckt nicht ..

Hallo,

ich habe das Problem, dass er nach einer Neuinstallation von BBX 4.1.3 einfach nicht drucken will.
Treiber: HP LJ 4L
Drucken über BIOS
Genau diese Einstellungen gehen bei meinem alten System.

Hat jemand irgendeine Idee?

Gruß
Rainer
Es gibt 10 Arten von Menschen - die einen wissen was binär ist, die anderen nicht.

Frank9652

Fortgeschrittener

  • »Frank9652« ist der Autor dieses Themas

Beiträge: 427

Beruf: Backup-Administrator

  • Nachricht senden

5

Sonntag, 8. November 2009, 12:51

Das du die anderen Einstellungen ausprobiert hast, braucht man dich wahrscheinlich nicht zu fragen?

Evtl. mal die Treiber mit älteren Druckertreibern vergleichen (Datum) und austauschen?

Wenn es dir nicht zu viel Mühe macht, dann bring doch den Drucker mal mit, dann können wir an anderen Geräten den Drucker mal testen und evtl. eine brauchbare Lösung finden.

...wenn alle Stricke reißen, dann fällt mir der Umweg nur über PDF ein, und Ausdruck unter Windoof.

Hast du (irgend) ein Windoof auf demselben Rechner?
Druckt er dann darunter?
Vielleicht liegt es ja nicht an der Software, und es ist wieder so ein Murphy-Gesetz das besagt...
...wenn du eine Software installierts, dann geht garantiert dabei der Drucker kaputt...

Bring das Teil mal mit, and we will see.

Gruß Frank
Geos + Lenovo Ideapad 5 = Aufbruch in eine neue Galaxie

6

Sonntag, 8. November 2009, 13:11

RE: Druckt nicht ..

Zitat

Original von Rainer
Hallo,

ich habe das Problem, dass er nach einer Neuinstallation von BBX 4.1.3 einfach nicht drucken will.
Treiber: HP LJ 4L
Drucken über BIOS
Genau diese Einstellungen gehen bei meinem alten System.

Hat jemand irgendeine Idee?


Hallo Rainer, ich habe auf meinem Rechner Deine Einstellungen ausprobiert. Bei mir funktioniert es, egal ob ich BIOS oder DOS einstelle. Ist BBX eine reine DOS-Installation?

Gruß

Jens
- geos-tiger -
- geos-tiger -

7

Sonntag, 8. November 2009, 14:45

Hallo Rainer.
Mit welchem BS läuft dein GEOS? Wenn es unter Windows laufen sollte, dann versuch mal, in den Windows-Druckeranschlußeinstellungen die Option "DOS-Druckauftrag zwischenspeichern" zu deaktivieren.
Gruß Achim



PC/GEOS unter Linux in der DOSEMU = UNSCHLAGBAR!

8

Sonntag, 8. November 2009, 15:24

Hi,

ich hab das BBX parallel zu einem vorhanden GEOS unter plain DOS installiert. Starte ich das alte GEOS, druckt er, wie seit Jahrzehenten...
Nur mit BBX will er nicht.
Also kein Hardware -Problem. Und nix mit Windows. Ich tipp auf ein INI-Problem.
Ich probier mal noch ein bisschen rum...

Gruß
Rainer
Es gibt 10 Arten von Menschen - die einen wissen was binär ist, die anderen nicht.

Frank9652

Fortgeschrittener

  • »Frank9652« ist der Autor dieses Themas

Beiträge: 427

Beruf: Backup-Administrator

  • Nachricht senden

9

Mittwoch, 11. November 2009, 17:40

Habs jetzt mal ausprobiert!
Hatte bisher keine Zeit, und das Druckerpapier war alle.

Bei mir funktioniert drucken auch nicht.
Unter der Version 4.022 geht es, unter 4.13 nicht
Das schreit nach einem Patch

Verwendeter Drucker: HP Deskjet 610C
Verwendeter Geos-Druckertreiber auf beiden Versionen:
HP DeskJet 1600C (s/w) und auch (4 Farben) an LPT1

Gruß Frank
Geos + Lenovo Ideapad 5 = Aufbruch in eine neue Galaxie

10

Mittwoch, 11. November 2009, 20:44

Zitat

Original von Frank9652
Habs jetzt mal ausprobiert!
... Bei mir funktioniert drucken auch nicht.
Unter der Version 4.022 geht es, unter 4.13 nicht
Das schreit nach einem Patch
...
Gruß Frank


geht die englische 4.13? und geht es nur in der deutschen nicht? Dann habe ich vielleicht beim Übersetzen einen Fehler reingearbeitet... *würg*
Gruss Johannes

=================================
www.moellerjaner.de
www.kirche-geithain.de
=================================

11

Mittwoch, 11. November 2009, 20:55

Deutsche Version

Hallo Johannes und alle anderen.
In meiner deutschen Version BBX 4.13 drucken meine Drucker; sowohl der Tintenstrahler HP Deskjet 990Cxi mit dem GEOS-Treiber HP Deskjet 1600C (und dieser als auf 600 dpi gepatchter) als auch der HP Color Laserjet 4550 mit dem HP Postscript-Druckertreiber in GEOS.
Allerdings läuft bei mir GEOS in einer Linux/DOSEMU-Kombination.
Gruß Achim



PC/GEOS unter Linux in der DOSEMU = UNSCHLAGBAR!

12

Mittwoch, 11. November 2009, 21:32

RE: Deutsche Version

Zitat

Original von Achim
Hallo Johannes und alle anderen.
In meiner deutschen Version BBX 4.13 drucken meine Drucker; sowohl der Tintenstrahler HP Deskjet 990Cxi mit dem GEOS-Treiber HP Deskjet 1600C (und dieser als auf 600 dpi gepatchter) als auch der HP Color Laserjet 4550 mit dem HP Postscript-Druckertreiber in GEOS.
Allerdings läuft bei mir GEOS in einer Linux/DOSEMU-Kombination.


Bei mir druckt die gepatchte Version auch nicht (Drucker braucht ihre Aufmerksamkeit...), deutsches Breadbox Ensemble 2007 Version 4.1.2 druckt.
Ungepatchte 4.13 nicht getestet.
GEOS läuft bei mir auch in einer Linux/DOSEMU-Kombination.

Wolfgang

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »geobart« (11. November 2009, 21:34)


13

Mittwoch, 11. November 2009, 21:50

Druckt jetzt :-)

Hallo,

wie vermuitet, ein INI-Problem. Aber der Reihe nach:

1. Kopieren einer funktionierenden INI nach BBX 4.1.3
---> druckt
2. Installieren der einen englischen Version
--> druckt
3. Vergleich der INI's

Englisch:
[HP LaserJet 4L on LPT1]
driver = HP PCL Level 4 driver
device = HP LaserJet 4L
port = LPT1
type = 0
[printer]
printers = HP LaserJet 4L on LPT1
numPrinters = 1
count = 1

Deutsch:
[HP LaserJet 4L ein LPT 1]
driver = HP PCL Level 4 driver
device = HP LaserJet 4L
port = LPT 1
type = 0
[printer]
printers = HP LaserJet 4L ein LPT 1
numPrinters = 1
count = 1

Unterschiede:
---------------
1.
[HP LaserJet 4L on LPT1] wurde mit
[HP LaserJet 4L ein LPT 1] übersetzt (statt an LPT1)
Das ist eher als lustiger Bug zu sehen, denn es handelt sich um einen Verweis innerhalb der INI. Solange der Eintrag
printers = ...
mit dem [.. ] Eintrag übereinstimmt ist alles OK. Was wahrscheinlich sogar automatisch passiert.

2.
englisch: port = LPT1
deutsch: port = LPT 1
Da haben wir das Problem.
Flugs das Leerzeichen weg, schon druckt es.

Gruß
Rainer
Es gibt 10 Arten von Menschen - die einen wissen was binär ist, die anderen nicht.

14

Donnerstag, 12. November 2009, 00:15

RE: Druckt jetzt :-)

Zitat

Original von Rainer

Unterschiede:
---------------
1.
[HP LaserJet 4L on LPT1] wurde mit
[HP LaserJet 4L ein LPT 1] übersetzt (statt an LPT1)
Das ist eher als lustiger Bug zu sehen, denn es handelt sich um einen Verweis innerhalb der INI. Solange der Eintrag
printers = ...
mit dem [.. ] Eintrag übereinstimmt ist alles OK. Was wahrscheinlich sogar automatisch passiert.

2.
englisch: port = LPT1
deutsch: port = LPT 1
Da haben wir das Problem.
Flugs das Leerzeichen weg, schon druckt es.

Gruß
Rainer


Stimmt. Es druckt.

Nun wollte ich mal ordentlich sein und habe auch aus dem "ein" ein "an" gemacht und wollte drucken:
Meldung: "Es ist kein Drucker installiert" obwohl er sichtbar in den Druckervoreinstellungen angezeigt wird - und lässt sich auch nicht löschen usw.
Also, Schreibfehler drinlassen, da sonst Verweis ins Nirwana, und nur Leerzeichen weg.
:D ;)

Wolfgang

15

Donnerstag, 12. November 2009, 09:04

RE: Druckt jetzt :-)

Zitat

Original von geobart: Nun wollte ich mal ordentlich sein und habe auch aus dem "ein" ein "an" gemacht und wollte drucken:
Meldung: "Es ist kein Drucker installiert" obwohl er sichtbar in den Druckervoreinstellungen angezeigt wird - und lässt sich auch nicht löschen usw.
Also, Schreibfehler drinlassen, da sonst Verweis ins Nirwana

Das Wort muss direkt in den übersetzten Dateien korrigiert werden, weil sonst der abgefragte Text-String nicht übereinstimmt.

Bernd

16

Sonntag, 15. November 2009, 19:09

Hallo zusammen,

Zitat

Original von JMGeithain

Zitat

Original von Frank9652
Habs jetzt mal ausprobiert!
... Bei mir funktioniert drucken auch nicht.
Unter der Version 4.022 geht es, unter 4.13 nicht
Das schreit nach einem Patch
...
Gruß Frank


geht die englische 4.13? und geht es nur in der deutschen nicht? Dann habe ich vielleicht beim Übersetzen einen Fehler reingearbeitet... *würg*


Bei mir funktioniert das Drucken einwandfrei unter Windows XP. Schnittstelleneinstellung: DOS
Der Drucker ist an die parallele Schnittstelle angeschlossen.
Noch etwas Anderes: Hat schon jemand versucht, den Import/Export-Filter für Word 8 aus der NewDeal 3.2a in Ensemble 4.13 einzusetzen? Bei mir wird auch mit diesem Filter nur der Import unterstützt.

Gruß
Wilfried

17

Sonntag, 15. November 2009, 21:27

Filter

Hallo Wilfried.
Dieser Filter ist ein reiner Importfilter, einen Exportfilter nach Word8 gibt es meines Wisseens nicht. ;(
Gruß Achim



PC/GEOS unter Linux in der DOSEMU = UNSCHLAGBAR!

18

Montag, 16. November 2009, 09:41

RE: Filter

Hallo,

Zitat

Original von Wilfried
Noch etwas Anderes: Hat schon jemand versucht, den Import/Export-Filter für Word 8 aus der NewDeal 3.2a in Ensemble 4.13 einzusetzen? Bei mir wird auch mit diesem Filter nur der Import unterstützt.


Ich verstehe die Frage nicht, da bei BBE doch bereits ein "Word8"-Importfilter mitgeliefert wird!?

Zitat

Original von Achim
Dieser Filter ist ein reiner Importfilter, einen Exportfilter nach Word8 gibt es meines Wisseens nicht.


Bei einigen Versionen von NDO2000 (und vermutlich auch schon beim GPC) gab's einen solchen "Exportfilter". Allerdings war's eine "Mogelpackung", da lediglich der "Rich Text Format (RTF)"-Export benutzt wurde und die Dateien dabei nur als .doc (anstelle von .rtf) abgelegt wurden. So richtig brauchen tut man dieses "Feature" übrigens nicht:
a) Ist "Word" das einzige Textprogramm auf einem Windows-PC, startet ein Doppelklick auf eine RTF-Datei sowieso "Word".
b) Die "falsche" Dateiendung kann sogar dazu führen, daß einige Virenscanner Alarm schlagen.

Gruß,
Jörg
:D Most favorite keys by profession: astronauts: space, pirates: enter, German teachers: 6... :D

19

Montag, 16. November 2009, 16:19

RE: Filter

Hallo Achim,

Zitat

Original von Achim
Hallo Wilfried.
Dieser Filter ist ein reiner Importfilter, einen Exportfilter nach Word8 gibt es meines Wisseens nicht. ;(


In ND 3.2a kann man auch nach Word 8 exportieren. Und den Export benötige ich häufiger.
Ich habe diesen Filter nach Ensemble kopiert, aber hier bietet er den Export nicht an.

Gruß
Wilfried

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Wilfried« (16. November 2009, 16:21)


Thema bewerten